Forums = vBulletin or phpbb?

All things techie, be they discussions on troubleshooting, video encoding, programming, or algorithm design.

Moderator: Nuxius

Forums = vBulletin or phpbb?

Postby Dev » Thu Oct 26, 2006 12:56 am

OK, so I'm searching on both vBulletin and phpbb forums for a good forum host. I don't know what to pick. I'm abit on the phpbb side because mainly, Terrafrost is a mod at phpbb.com and he's probably a king at this stuff and I can get some good help from phpbb since.. Terrafrost is a mod there. vBulletin, they have some cool forums there that look good and all.

...


I'm probably going to get tons of replies to get phpbb.

EDIT: AHHHH, wait a second! So phpbb is just forum software and vBulletin is website and forum software!


Aargh! I'm so confused! My mind feels like exploding! phpbb has forum hosting that lets you install mods and shit on it right? Yes, yes, I use those free forum hosts - [url]matsikameswiftrp.jconserv.net[/url] - but I want to do my own things on it!
Fosty wrote:"My fake plants died because I forgot to pretend to water them."
- Mitch Hedberg

CrustyPunk wrote:Talk to Orion. He plays gee-tar."


Funny men
User avatar
Dev
Elite Guard
 
Posts: 1678
Joined: Fri Jul 11, 2003 3:56 pm
Location: low-temperature penis - cold cock. It actually means the stock of a weapon.

Postby Megafrost » Thu Oct 26, 2006 4:23 pm

phpBB!

All the cool jedis are doing it. :p
The universe is mine and all shall bow before the might of Megafrost, master of Orion, master of the universe...
User avatar
Megafrost
Frost Blacksmith
Frost Blacksmith
 
Posts: 5249
Joined: Thu Dec 05, 2002 4:15 pm
Location: The planet of Cybertron

Postby Drazo » Sun Oct 29, 2006 4:59 pm

phpBB - Written in PHP, free and open source but full of security holes. Hackers and spammers love it too.
vBulletin - Written in PHP, costs quite a bit but is securer and has more features and such already implanted.

If you're installing a forum for a major (busy) community/site and have some money to spare then I recommend vBulletin, otherwise phpBB for lesser exposed sites.

(I prefer phpBB forums, usually)
[Don't watch here carefully]
User avatar
Drazo
Heroic Guard
 
Posts: 3935
Joined: Mon Jan 06, 2003 8:59 pm

Postby TerraFrost » Mon Oct 30, 2006 11:35 pm

...full of security holes.

Though FJ may be full of holes, I don't agree that phpBB, itself, is full of holes.

FJ has been heavily modded. This, for one, makes it hard to upgrade. It also means that FJ has a lot more potential problem areas. If you have a virgin phpBB, the only people you have to worry about introducing vulnerabilities is the phpBB Group - a group that isn't likely to introduce them. In contrast, if you have tons of modifications installed, you have to worry about each and every author of those modifications introducing vulnerabilities. This is just as true for phpBB as it is for vBulletin.

Long story short, I suspect FJ has no one to blame for its hackings other then me (well, and the hacker, too!). For not keeping it and all its modifications up-to-date, etc. And since doing so would be a full time job, I suspect, the only viable and permanent solution, for FJ, is going to be to just introduce a v3 (this is v2; v3 would take a fair amount of work, although almost certainly less than v2 did).
TerraFrost
Legendary Guard
 
Posts: 12357
Joined: Wed Dec 04, 2002 6:37 am

Postby Dev » Tue Oct 31, 2006 8:34 pm

That's alright guys, I already bought a domain and phpBB was included with it and shit. Problem is that I keep getting a damn "Cannot Connect To Database" error when I switch it to MYSQL 4. I had to put it to MYSQL 4 because it seems my host or whatever has MYSQL 4.

Fortunately, I did do a search on the phpBB forums multiple times, only to come up empty-handed and/or the search link crashes on me whenever I search for "Cannot connect to database"

EDIT: OK, So I correctly updated it but now I get the phpbb critical error "cannot find valid language pack error".

I aearched and searched, and came up with some shit but they didn't help. I looked in phpmyadmin for that phpbb_config thing and found it, then looked for default_lang and I could not find it. HELP!
Fosty wrote:"My fake plants died because I forgot to pretend to water them."
- Mitch Hedberg

CrustyPunk wrote:Talk to Orion. He plays gee-tar."


Funny men
User avatar
Dev
Elite Guard
 
Posts: 1678
Joined: Fri Jul 11, 2003 3:56 pm
Location: low-temperature penis - cold cock. It actually means the stock of a weapon.

Postby Drazo » Sat Nov 04, 2006 3:25 am

TerraFrost wrote:
...full of security holes.

Though FJ may be full of holes, I don't agree that phpBB, itself, is full of holes.

FJ has been heavily modded. This, for one, makes it hard to upgrade. It also means that FJ has a lot more potential problem areas. If you have a virgin phpBB, the only people you have to worry about introducing vulnerabilities is the phpBB Group - a group that isn't likely to introduce them. In contrast, if you have tons of modifications installed, you have to worry about each and every author of those modifications introducing vulnerabilities. This is just as true for phpBB as it is for vBulletin.

Long story short, I suspect FJ has no one to blame for its hackings other then me (well, and the hacker, too!). For not keeping it and all its modifications up-to-date, etc. And since doing so would be a full time job, I suspect, the only viable and permanent solution, for FJ, is going to be to just introduce a v3 (this is v2; v3 would take a fair amount of work, although almost certainly less than v2 did).


*says no more* :biggrin

<.<;
[Don't watch here carefully]
User avatar
Drazo
Heroic Guard
 
Posts: 3935
Joined: Mon Jan 06, 2003 8:59 pm

Postby TerraFrost » Mon Nov 06, 2006 9:40 pm

Dev wrote:That's alright guys, I already bought a domain and phpBB was included with it and shit. Problem is that I keep getting a damn "Cannot Connect To Database" error when I switch it to MYSQL 4. I had to put it to MYSQL 4 because it seems my host or whatever has MYSQL 4.

Fortunately, I did do a search on the phpBB forums multiple times, only to come up empty-handed and/or the search link crashes on me whenever I search for "Cannot connect to database"

EDIT: OK, So I correctly updated it but now I get the phpbb critical error "cannot find valid language pack error".

I aearched and searched, and came up with some shit but they didn't help. I looked in phpmyadmin for that phpbb_config thing and found it, then looked for default_lang and I could not find it. HELP!

My guess would be that you don't have any directories in the language directory. There should be one for each language your board supports - lang_english, lang_turkish, lang_whatever. Within each of those directories, there should be two files - lang_main.php and lang_admin.php.

Also, what's the URL to your board?
TerraFrost
Legendary Guard
 
Posts: 12357
Joined: Wed Dec 04, 2002 6:37 am

Postby Dev » Tue Nov 07, 2006 5:19 am

That's alright, I fixed it. I just added the default_lang field with english for the right part or whatever.

The URL to my board is msroleplay.com
Fosty wrote:"My fake plants died because I forgot to pretend to water them."
- Mitch Hedberg

CrustyPunk wrote:Talk to Orion. He plays gee-tar."


Funny men
User avatar
Dev
Elite Guard
 
Posts: 1678
Joined: Fri Jul 11, 2003 3:56 pm
Location: low-temperature penis - cold cock. It actually means the stock of a weapon.

Postby Drazo » Mon Nov 20, 2006 12:29 pm

You might want to consider upgrading to phpBB 3 too, once it's out.
[Don't watch here carefully]
User avatar
Drazo
Heroic Guard
 
Posts: 3935
Joined: Mon Jan 06, 2003 8:59 pm


Return to Communications Center

Who is online

Users browsing this forum: No registered users and 3 guests

cron