Birthday mod displaying wrong date

Advertise a phpBB hack or request help with an existing one.

Moderator: TerraFrost

Birthday mod displaying wrong date

Postby fear » Tue Feb 14, 2006 2:38 am

I have installed the birthday mod and now it is displaying the wrong date in the user profile.

Does any one know what the problem may be?
fear
Traveler
 
Posts: 6
Joined: Tue Feb 14, 2006 2:25 am

Postby TerraFrost » Tue Feb 14, 2006 5:33 am

Your description is kinda vague. How is the date wrong? Is the birthday showing up as being a day early?

Also, what version of the Birthday MOD are you running?
TerraFrost
Legendary Guard
 
Posts: 12357
Joined: Wed Dec 04, 2002 6:37 am

Postby fear » Tue Feb 14, 2006 2:30 pm

Its a day later, then what is suppost to be, My birthday is Oct 14 and it shows up in my profile as Oct 15.

Everyone has the same problem.

Version 2.0.0
fear
Traveler
 
Posts: 6
Joined: Tue Feb 14, 2006 2:25 am

Postby TerraFrost » Tue Feb 14, 2006 9:46 pm

At the top of most styles, the current time is given. eg:

The time now is Tue Feb 14, 2006 3:41 pm

Is the date, there, off by a day, as well?

In any case, this is pretty clearly a timezone problem. Quite a few people had a problem like this in v1.0.0, but your the first person I'm aware of whose experiencing this problem on v2.0.0 (and you're far from the first person to install v2.0.0). This leads me to suspect that the problem isn't so much with my MOD as it is with your board settings.
TerraFrost
Legendary Guard
 
Posts: 12357
Joined: Wed Dec 04, 2002 6:37 am

Postby fear » Tue Feb 14, 2006 11:31 pm

the time and day is correct on the site. Hmm, I will keep looking, If I figure it out, I will let you know what it was.

What was the fix back in version 1.0.0?
fear
Traveler
 
Posts: 6
Joined: Tue Feb 14, 2006 2:25 am

Postby fear » Wed Feb 15, 2006 12:04 am

I figured it out.

I went into the database and the birthday field was correct but there was a user_pc_timeOffsets was set to -21600/1520 and it was set to a few different offsets on a few about 30 members. I set that field to 0 and everything is shows up correctly now.
fear
Traveler
 
Posts: 6
Joined: Tue Feb 14, 2006 2:25 am

Postby TerraFrost » Wed Feb 15, 2006 6:40 am

Glad to here it! :)

Based on what you updated, though, I'm guessing you have -=ET=-'s timezone MOD?
TerraFrost
Legendary Guard
 
Posts: 12357
Joined: Wed Dec 04, 2002 6:37 am

Postby fear » Wed Feb 15, 2006 1:59 pm

No I am running Nuke Evolution with no Timezone mod. The time on the site is set to pull your local time from your computer.

I think the problem was because I recently upgraded from standard nuke to evo and everyone set there own timeszones on standard nuke. Then when we switched over the settings stayed in the database.
Last edited by fear on Wed Feb 15, 2006 2:02 pm, edited 1 time in total.
fear
Traveler
 
Posts: 6
Joined: Tue Feb 14, 2006 2:25 am

Postby fear » Wed Feb 15, 2006 2:00 pm

;)
fear
Traveler
 
Posts: 6
Joined: Tue Feb 14, 2006 2:25 am


Return to phpBB Hacks and MODs

Who is online

Users browsing this forum: No registered users and 1 guest

cron