try it now!

Advertise a phpBB hack or request help with an existing one.

Moderator: TerraFrost

Postby Chicago 2003 » Thu Apr 22, 2004 4:50 am

thanks ^^
Chicago 2003
Traveler
 
Posts: 3
Joined: Mon Apr 19, 2004 5:15 pm

Postby Evlfrost » Thu Apr 22, 2004 5:06 am

Hmm...its still doing a lot of vertical scrolling for me.
Evljsh: You're young and thus illegal!
xXOkashiiSuruXx: -falls over-

Image
User avatar
Evlfrost
Frost Druid
Frost Druid
 
Posts: 6692
Joined: Thu Dec 05, 2002 2:41 pm
Location: Suburbia

Postby Wolfie » Thu Apr 22, 2004 5:10 am

MOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO!
ЀA†H comes like £iƒε,
sometimes forced and unwanted and sometimes loved and longed for.
How will you Ði€?™
User avatar
Wolfie
Legendary Guard
 
Posts: 7365
Joined: Sun Oct 19, 2003 2:13 am
Location: Somewhere between now and then.

Postby Wolfie » Thu Apr 22, 2004 5:10 am

work perfect fr me
ЀA†H comes like £iƒε,
sometimes forced and unwanted and sometimes loved and longed for.
How will you Ði€?™
User avatar
Wolfie
Legendary Guard
 
Posts: 7365
Joined: Sun Oct 19, 2003 2:13 am
Location: Somewhere between now and then.

Postby TerraFrost » Thu Apr 22, 2004 5:52 am

Hmm...its still doing a lot of vertical scrolling for me.


yeah... i've removed the "<br>" tag for testing purposes.

the problem, as i've learned, is that ! (and a few other characters) are defined, by some unicode standard, not to allow page breaks before them. you can read about this, here:

http://www.unicode.org/reports/tr14/

not all browsers are implemented in accordance with this browser (IE 6 and Opera 7 are), but those that are are used rather prominently. and personally, i think its a stupid feature, anyways, but ah well, heh.

another temporary fix would be to replace the afore mentioned line with this:

Code: Select all
         $finalText .= $tempText . $curChar . " &nbsp;";


however, both fixes still fail on certain conditions. ie. "! ! ! ! ! " repeated endlessly.
TerraFrost
Legendary Guard
 
Posts: 12357
Joined: Wed Dec 04, 2002 6:37 am

Postby Evlfrost » Thu Apr 22, 2004 6:35 am

Edit: yeah I would say that
Evljsh: You're young and thus illegal!
xXOkashiiSuruXx: -falls over-

Image
User avatar
Evlfrost
Frost Druid
Frost Druid
 
Posts: 6692
Joined: Thu Dec 05, 2002 2:41 pm
Location: Suburbia

Postby TerraFrost » Sat Apr 24, 2004 12:28 am

the exception i mentioned earlier - the one that i said word wrapping wouldn't work on... it now does...

! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! !

on top of that, my algo is a tad nicer, too. i'll release it on saturday :)
TerraFrost
Legendary Guard
 
Posts: 12357
Joined: Wed Dec 04, 2002 6:37 am

Postby TerraFrost » Sun Apr 25, 2004 12:18 am

TerraFrost
Legendary Guard
 
Posts: 12357
Joined: Wed Dec 04, 2002 6:37 am

Postby Chicago 2003 » Fri Apr 30, 2004 3:37 am

thank you very much TerraFrost, u rox!!
Chicago 2003
Traveler
 
Posts: 3
Joined: Mon Apr 19, 2004 5:15 pm


Postby Jims » Sat Sep 11, 2004 10:32 pm

Jims wrote:http://images.google.com/imgres?imgurl=http://www.ihateaol.co.uk/misc/galleries/show.php/640x640/funnypics/google.gif&imgrefurl=http://www.absforums.com/index.php%3Fshowtopic%3D11134%26view%3Dgetnewpost&h=396&w=640&sz=282&tbnid=UV6ptBvy6xkJ:&tbnh=83&tbnw=134&start=1&prev=/images%3Fq%3Dphp%26svnum%3D30%26hl%3Den%26lr%3D%26ie%3DUTF-8%26newwindow%3D1%26safe%3Doff%26sa%3DG

http://images.google.com/imgres?imgurl= ... f%26sa%3DG

http://images.google.com/imgres?imgurl= ... f%26sa%3DG

http://images.google.com/imgres?imgurl= ... f%26sa%3DG

http://images.google.com/imgres?imgurl= ... f%26sa%3DG

http://images.google.com/imgres?imgurl= ... f%26sa%3DG

http://images.google.com/imgres?imgurl= ... f%26sa%3DG


Nice! Good work!

EDIT: Testing
Jims
Traveler
 
Posts: 4
Joined: Sat Sep 11, 2004 10:25 pm

Postby Jims » Sat Sep 11, 2004 10:33 pm

Jims wrote:
Jims wrote:http://images.google.com/imgres?imgurl=http://www.ihateaol.co.uk/misc/galleries/show.php/640x640/funnypics/google.gif&imgrefurl=http://www.absforums.com/index.php%3Fshowtopic%3D11134%26view%3Dgetnewpost&h=396&w=640&sz=282&tbnid=UV6ptBvy6xkJ:&tbnh=83&tbnw=134&start=1&prev=/images%3Fq%3Dphp%26svnum%3D30%26hl%3Den%26lr%3D%26ie%3DUTF-8%26newwindow%3D1%26safe%3Doff%26sa%3DG

http://images.google.com/imgres?imgurl= ... f%26sa%3DG

http://images.google.com/imgres?imgurl= ... f%26sa%3DG

http://images.google.com/imgres?imgurl= ... f%26sa%3DG

http://images.google.com/imgres?imgurl= ... f%26sa%3DG

http://images.google.com/imgres?imgurl= ... f%26sa%3DG

http://images.google.com/imgres?imgurl= ... f%26sa%3DG


Nice! Good work!


Seems to be a little scrolling after quoting... but it's a LOT better than what normally happens.

EDIT: testing.
Jims
Traveler
 
Posts: 4
Joined: Sat Sep 11, 2004 10:25 pm

Postby Jims » Sat Sep 11, 2004 10:37 pm

Another test
http://images.google.com/imgres?imgurl=http://www.ihateaol.co.uk/misc/galleries/show.php/640x640/funnypics/google.gif&imgrefurl=http://www.absforums.com/index.php%3Fshowtopic%3D11134%26view%3Dgetnewpost&h=396&w=640&sz=282&tbnid=UV6ptBvy6xkJ:&tbnh=83&tbnw=134&start=1&prev=/images%3Fq%3Dphp%26svnum%3D30%26hl%3Den%26lr%3D%26ie%3DUTF-8%26newwindow%3D1%26safe%3Doff%26sa%3DG


It didn't make the first one a link after quoting it, I'm seeing if that happens again (But really, how often would someone be looking to click a link in a quote?)

EDIT: testing.
Jims
Traveler
 
Posts: 4
Joined: Sat Sep 11, 2004 10:25 pm

Postby TerraFrost » Sat Sep 11, 2004 11:49 pm

that's really weird, heh.

the non-clickable link seems to be a problem with phpbb, itself, however, as evident by the fact that it has this same problem without my script, too:

http://www.phpbb.com/phpBB/viewtopic.ph ... 25#1239925

as for the wrapping probs... i'm not really sure what's causing those, either, actually. a more detailed investigation is in order. thanks for alerting me to 'em! :)
TerraFrost
Legendary Guard
 
Posts: 12357
Joined: Wed Dec 04, 2002 6:37 am

]]]]]]]]]]]]]]]]]]]]]]]]]]]

Postby black712 » Wed Jun 01, 2005 11:34 am

]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]
black712
Traveler
 
Posts: 1
Joined: Wed Jun 01, 2005 11:32 am

PreviousNext

Return to phpBB Hacks and MODs

Who is online

Users browsing this forum: No registered users and 1 guest

cron